pear.php.net is using a unsupported protocol – This should never happen.

I ran into the error “pear.php.net is using a unsupported protocol – This should never happen.” when I tried to upgrade my pecl packages. I have to say errors like “this should never happen” shouldn’t happen, but since it obviously did what is the cause and more importantly the solution. Apparently this error is caused because PHP 5.2.9 and 5.2.10 were broken and it corrupted the .record folder. The solution to fix this is to upgrade pear first then pecl.

pear upgrade
pecl upgrade

So simple :)

One comment on “pear.php.net is using a unsupported protocol – This should never happen.
  1. Thanks very much for the info: fixes exactly the problem I was having. Just left with “Unknown remote channel: guzzlephp.org/pear” now…

Leave a Reply

Your email address will not be published. Required fields are marked *